The browser you are using is not compliant with the new security protocol that will be installed in 47 days. The minimum browser requirements for NJMMIS.com will be:

Chrome version 31
Firefox version 27
Internet Explorer 11
Apple Safari 7

If the browser is not upgraded, you will not be able to access NJMMIS.COM after 47 days. If you are getting this message and using Internet Explorer 11, you must take the browser out of Enterprise Mode. Enterprise Mode forces the browser to work like IE 8, which is not compatible. Information about Enterprise mode can be found in the IE11 Support Document.

If you need assistance upgrading your browser, please contact your system administrator.

Welcome to NJMMIS.com
Home Site Requirements Help Index by Topic State Web Sites HIPAA Submitter Login Reset Password Login   Contact Provider Services   Contact Webmaster   Fed & State Stats & Regs   Forgot My Password   Provider Directory   Provider Enrollment zApplication   Provider Registration   Approved Vendor List   Billing Supplements / Training Packets   Recent Newsletters   Edit Codes   FAQ   Forms & Documents   Physician Administered
  Drugs (UOM)
  Rate and Code Information   Newsletters & Alerts   NJ State MAC